ar71xx: fix build of lzma-loader with binutils 2.25.1
[openwrt/staging/chunkeey.git] / target / linux / ar71xx / image / lzma-loader / src / Makefile
index 8038b2fba9375a42db4be8af98407845b6c80e37..5f10bdb8f1499f24f00a8bf4d53f370fef88bd1e 100644 (file)
@@ -27,7 +27,8 @@ LD            := $(CROSS_COMPILE)ld
 OBJCOPY                := $(CROSS_COMPILE)objcopy
 OBJDUMP                := $(CROSS_COMPILE)objdump
 
-BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+                  -R .MIPS.abiflags -S
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \