some platform support path name cleanup
[openwrt/staging/chunkeey.git] / target / linux / aruba-2.6 / image / Makefile
index 37dd6fccb04ae63c29d014aa431fd858386c2dfb..e486b30ef2058251afd4d47d364afee6527d7f36 100644 (file)
@@ -18,12 +18,12 @@ LOADER_MAKEOPTS= \
                RAMSIZE=$(RAMSIZE)
 
 define Build/Clean
-       $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
 endef
 
 define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-       $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
 endef
 
 define Image/BuildKernel