brcm47xx/bcm53xx: improve description
[openwrt/staging/chunkeey.git] / target / linux / bcm53xx / Makefile
index 7fe31620542131d40115508fd8ca87c2f1af6152..f9d7e32454be935f2cf9e7927b5bfc4220180198 100644 (file)
@@ -8,11 +8,12 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.1
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,10 +21,8 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
-
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += swconfig wpad-mini
 
 $(eval $(call BuildTarget))