bcm53xx: convert (disabled) Netgear R8500 image to own profile
[openwrt/staging/chunkeey.git] / target / linux / bcm53xx / image / Makefile
index d9d4a80fa1098781799c318078bf7fe2356611ca..6b2b62a99126e30e375a5cc9baa7ab70f48152e9 100644 (file)
@@ -8,8 +8,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       $(CP) $(DTS_DIR)/*.dtb $(KDIR)/
-
        rm -f $(KDIR)/fs_mark
        echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
@@ -17,28 +15,20 @@ define Image/Prepare
        # For UBI we want only one extra block
        rm -f $(KDIR)/ubi_mark
        echo -ne '\xde\xad\xc0\xde' > $(KDIR)/ubi_mark
-
-       $(CP) ./ubinize.cfg $(KDIR)
-endef
-
-define Build/append-dtb
-       cat $(KDIR)/$(DT).dtb >> $@
 endef
 
 define Build/lzma-d16
        $(STAGING_DIR_HOST)/bin/lzma e $@ -d16 $(1) $@.new
-       @mv $@.new $@
-endef
-
-define Build/mkfs/squashfs
-       ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
+       mv $@.new $@
 endef
 
 define Build/trx-serial
        $(STAGING_DIR_HOST)/bin/trx \
-               -o $@ \
-               -f $(word 1,$^) -a 1024 \
-               -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+               -o $@.new \
+               -m 33554432 \
+               -f $(IMAGE_KERNEL) -a 1024 \
+               -f $@ -a 0x10000 -A $(KDIR)/fs_mark
+       mv $@.new $@
 endef
 
 define Build/trx-nand
@@ -47,11 +37,12 @@ define Build/trx-nand
        # root: UBI with one extra block containing UBI mark to trigger erasing
        #       rest of partition
        $(STAGING_DIR_HOST)/bin/trx \
-               -o $@ \
+               -o $@.new \
                -m 33554432 \
-               -f $(word 1,$^) -a 0x20000 -b 0x400000 \
-               -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
+               -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
+               -f $@ \
                -A $(KDIR)/ubi_mark -a 0x20000
+       mv $@.new $@
 endef
 
 define Build/asus-trx
@@ -60,24 +51,44 @@ define Build/asus-trx
        mv $@.new $@
 endef
 
-DEVICE_VARS += DT PRODUCTID NETGEAR_BOARD_ID NETGEAR_REGION
+define Build/seama-nand
+       # Seama entity
+       $(STAGING_DIR_HOST)/bin/oseama \
+               entity $@.entity \
+               -m "dev=/dev/mtdblock/7" \
+               -m "type=firmware" \
+               -f $(IMAGE_KERNEL) \
+               -b 0x400000 \
+               -f $@ \
+               -f $(KDIR)/ubi_mark
+       # Seama container
+       $(STAGING_DIR_HOST)/bin/seama \
+               -s $@ \
+               -m "signature=$(SIGNATURE)" \
+               -i $@.entity
+endef
+
+DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
 
 define Device/Default
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
   # extract the full dtb name based on the device info
-  DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+  DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
   KERNEL := kernel-bin | append-dtb | lzma-d16
-  KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
+  KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
   FILESYSTEMS := squashfs
   KERNEL_NAME := zImage
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
   IMAGES := trx
-  IMAGE/trx := trx-nand
+  BLOCKSIZE := 128KiB
+  PAGESIZE := 2048
+  UBINIZE_OPTS :=
+  IMAGE/trx := append-ubi | trx-nand
 endef
 
 define Device/asus
   IMAGES := trx
-  IMAGE/trx := trx-nand | asus-trx
+  IMAGE/trx := append-ubi | trx-nand | asus-trx
 endef
 
 define AsusDevice
@@ -88,21 +99,34 @@ define AsusDevice
   TARGET_DEVICES += asus-$(1)
 endef
 
-define Device/linksys
-  IMAGES := trx
-  IMAGE/trx := trx-nand
+define LinksysDevice
+  TARGET_DEVICES += linksys-$(1)
 endef
 
-define LinksysDevice
-  define Device/linksys-$(1)
-       $$(Device/linksys)
+define Device/dlink
+  IMAGES := bin
+  IMAGE/bin := append-ubi | seama-nand
+endef
+
+define DLinkDevice
+  define Device/dlink-$(1)
+       $$(Device/dlink)
+       SIGNATURE := $(2)
   endef
-  TARGET_DEVICES += linksys-$(1)
+  TARGET_DEVICES += dlink-$(1)
+endef
+
+define Device/dlink-dir-885l
+  DEVICE_TITLE := D-Link DIR-885L
+  DEVICE_PACKAGES := kmod-brcmfmac
+  $(Device/dlink)
+  SIGNATURE := wrgac42_dlink.2015_dir885l
 endef
+TARGET_DEVICES += dlink-dir-885l
 
 define Device/netgear
   IMAGES := chk
-  IMAGE/chk := trx-nand | netgear-chk
+  IMAGE/chk := append-ubi | trx-nand | netgear-chk
   NETGEAR_REGION := 1
 endef
 
@@ -124,14 +148,34 @@ define Device/netgear-r6300-v2
   NETGEAR_BOARD_ID := U12H240T00_NETGEAR
 endef
 
+define Device/netgear-r7900
+  DEVICE_TITLE := Netgear R7900
+  DEVICE_PACKAGES := kmod-brcmfmac
+  $(Device/netgear)
+  NETGEAR_BOARD_ID := U12H315T30_NETGEAR
+endef
+TARGET_DEVICES += netgear-r7900
+
 define Device/netgear-r8000
+  DEVICE_TITLE := Netgear R8000
+  DEVICE_PACKAGES := kmod-brcmfmac
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H315T00_NETGEAR
 endef
 
+define Device/netgear-r8500
+  DEVICE_TITLE := Netgear R8500
+  DEVICE_PACKAGES := kmod-brcmfmac
+  $(Device/netgear)
+  NETGEAR_BOARD_ID := U12H334T00_NETGEAR
+endef
+# TARGET_DEVICES += netgear-r8500
+
 define Device/smartrg-sr400ac
+  DEVICE_TITLE := SmartRG SR400ac
+  DEVICE_PACKAGES := kmod-brcmfmac
   IMAGES := trx
-  IMAGE/trx := trx-serial
+  IMAGE/trx := append-rootfs | trx-serial
 endef
 
 TARGET_DEVICES += \