bcm53xx: build images for Asus devices
[openwrt/staging/chunkeey.git] / target / linux / bcm53xx / image / Makefile
index 4b61e1330b2bab476e557c05bb6e764024bd1c3d..b22dfe59c5a38ec47c94bb500637bd9c03d76ff5 100644 (file)
@@ -54,13 +54,19 @@ define Build/trx-nand
                -A $(KDIR)/ubi_mark -a 0x20000
 endef
 
+define Build/asus-trx
+       $(STAGING_DIR_HOST)/bin/asustrx \
+               -p $(PRODUCTID) -i $@ -o $@.new
+       mv $@.new $@
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new -k $@ -b $(BOARD_ID) -r $(REGION)
        mv $@.new $@
 endef
 
-DEVICE_VARS += DT BOARD_ID REGION
+DEVICE_VARS += DT PRODUCTID BOARD_ID REGION
 
 define Device/Default
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
@@ -74,6 +80,19 @@ define Device/Default
   IMAGE/trx := trx-nand
 endef
 
+define Device/asus
+  IMAGES := trx
+  IMAGE/trx := trx-nand | asus-trx
+endef
+
+define AsusDevice
+  define Device/asus-$(1)
+       $$(Device/asus)
+       PRODUCTID := $(2)
+  endef
+  TARGET_DEVICES += asus-$(1)
+endef
+
 define Device/netgear
   IMAGES := chk
   IMAGE/chk := trx-nand | netgear-chk
@@ -101,10 +120,14 @@ define Device/smartrg-sr400ac
 endef
 
 TARGET_DEVICES += \
-       asus-rt-ac56u asus-rt-ac68u asus-rt-ac87u asus-rt-n18u \
        buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
        buffalo-wxr-1900dhp \
        netgear-r6250 netgear-r6300-v2 netgear-r8000 \
        smartrg-sr400ac
 
+$(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
+$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
+$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
+$(eval $(call AsusDevice,rt-n18u,RT-N18U))
+
 $(eval $(call BuildImage))