brcm2708: fix sdcard image
[openwrt/staging/chunkeey.git] / target / linux / brcm2708 / image / Makefile
index 8cf83a4563a7fc671750b414899648d2976fadc6..2d606e5649aa9be1d14a366d7e82e0e6ceb488eb 100644 (file)
@@ -1,16 +1,20 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016-2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
-include $(INCLUDE_DIR)/host.mk
 
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+define Build/Compile
+       $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+endef
+
 ### Image scripts ###
 define Build/kernel-img
        perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
@@ -20,8 +24,8 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/COPYING.linux ::
+       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
@@ -29,58 +33,53 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
-       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
-       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
+       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
        mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
 endef
 
 define Build/sdcard-img
-       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-       $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
-### Device macros ###
+### Devices ###
 define Device/Default
   FILESYSTEMS := ext4
-  PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL := kernel-bin | kernel-img
+  KERNEL_IMG := kernel.img
   IMAGES := sdcard.img
-  IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_PROFILE :=
-  DEVICE_DTS :=
+  IMAGE/sdcard.img := boot-img | sdcard-img | gzip | append-metadata
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
 
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define bcm27xx
-  define Device/$(2)
-    DEVICE_PROFILE := $(1)
-    DEVICE_DTS := $(3)
-  endef
-  TARGET_DEVICES += $(2)
+define Device/rpi
+  DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
+  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
+  SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
 endef
-
-### BCM2708/BCM2835 ###
 ifeq ($(SUBTARGET),bcm2708)
-  # Raspberry Pi Models B/B+/CM
-  $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+  TARGET_DEVICES += rpi
 endif
 
-### BCM2709/BCM2836 ###
+define Device/rpi-2
+  DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
+  DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
+  SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,compute-module-3
+endef
 ifeq ($(SUBTARGET),bcm2709)
-  # Raspberry Pi 2 Model B
-  $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+  TARGET_DEVICES += rpi-2
 endif
 
-### BCM2710/BCM2837 ###
+define Device/rpi-3
+  KERNEL_IMG := kernel8.img
+  DEVICE_TITLE := Raspberry Pi 3B (64 bit)
+  DEVICE_DTS := broadcom/bcm2710-rpi-3-b
+  SUPPORTED_DEVICES := rpi-3-b raspberrypi,3-model-b
+endef
 ifeq ($(SUBTARGET),bcm2710)
-  # Raspberry Pi 3 Model B
-  $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
+  TARGET_DEVICES += rpi-3
 endif
 
 $(eval $(call BuildImage))