brcm47xx: explicitely mention MIPS to avoid confusion
[openwrt/staging/chunkeey.git] / target / linux / brcm47xx / Makefile
index 06322d3a9da23e2fc5dd2f93c7712b47932f72b7..4576ac3c8c66368d46a0e92f0aea8d1b96d4b583 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
+FEATURES:=squashfs usb pcmcia
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=2.6.25.6
+LINUX_VERSION:=3.10.32
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
 
 define Target/Description
        Build firmware images for Broadcom based routers