update kernel versions
[openwrt/staging/chunkeey.git] / target / linux / ifxmips / Makefile
index e25eea8798e1d945151f555306ec3c3b41663a5a..65dbe2bded199dcca53fd21050cf74b59681e4ce 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.9
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
+
+LINUX_VERSION:=2.6.33.6
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
-define Target/Description
-       Build firmware images for Infineon Mips Controllers
-endef
+#define Target/Description
+#      Build firmware images for Infineon Mips Controllers
+#endef
 
 $(eval $(call BuildTarget))