image: use k as unit suffix for blocksize
[openwrt/staging/chunkeey.git] / target / linux / imx6 / image / Makefile
index 6b66376d41163ebc1195edb80b955ff65f9a7d90..86e3308c79fb934d3fc2bcceb2b7407b34687deb 100644 (file)
@@ -84,21 +84,23 @@ define Device/ventana
        imx6q-gw54xx \
        imx6q-gw5400-a \
        imx6q-gw551x \
-       imx6q-gw552x
+       imx6q-gw552x \
+       imx6q-gw553x
   DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
        kmod-can kmod-can-flexcan kmod-can-raw \
-       kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
+       kmod-hwmon-gsc \
        kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
        kobs-ng
   KERNEL += | boot-overlay
   IMAGES := nand.ubi bootfs.tar.gz
+  UBINIZE_OPTS :=
   UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
   IMAGE/nand.ubi := append-ubi
   IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)
   PAGESIZE := 2048
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB
 endef
 
@@ -108,7 +110,7 @@ define Device/ventana-large
   DEVICE_TITLE := Gateworks Ventana family (large NAND flash)
   IMAGES := nand.ubi
   PAGESIZE := 4096
-  BLOCKSIZE := 256KiB
+  BLOCKSIZE := 256k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB
 endef