ipq40xx: RT-AC58U: Try ARTIFACTS for install.trx
[openwrt/staging/chunkeey.git] / target / linux / ipq40xx / image / generic.mk
index 82df4472c9bcdb0c7336ffb38d9b8008c1b0d687..be313e672d3222ad5d07d7991027e49d64d8e2ee 100644 (file)
@@ -236,7 +236,7 @@ define Device/asus_rt-ac58u
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       IMAGE_SIZE := 20439364
+       IMAGE_SIZE := 20439300
        FILESYSTEMS := squashfs
 #      Someone - in their infinite wisdom - decided to put the firmware
 #      version in front of the image name \03\00\00\04 => Version 3.0.0.4
@@ -244,6 +244,9 @@ define Device/asus_rt-ac58u
 #      to add a version... or we are very careful not to add '\0' into that
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
+       ARTIFACTS := install.trx
+       ARTIFACT/install.trx := copy-file $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE) \
+               | pad-to $$$$(IMAGE_SIZE) | uImage none
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
                kmod-usb-ledtrig-usbport
 endef