ipq806x: drop ipq40xx support
[openwrt/staging/chunkeey.git] / target / linux / ipq806x / image / Makefile
index fa1791651469167475a59eed7855e4930e610d38..d41679ff97cb5b3c09b8bbaf32d9ea48458e2d0f 100644 (file)
@@ -73,21 +73,6 @@ define Device/ZyXELImage
        IMAGE/mmcblk0p4-kernel.bin := append-kernel
 endef
 
-define Device/avm_fritzbox-4040
-       $(call Device/FitImageLzma)
-       DEVICE_DTS := qcom-ipq4019-fritz4040
-       KERNEL_LOADADDR := 0x80208000
-       BLOCKSIZE := 4k
-       PAGESIZE := 256
-       BOARD_NAME := fritz4040
-       DEVICE_TITLE := AVM Fritz!Box 4040
-       IMAGE_SIZE := 29753344
-       IMAGES = sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := kmod-usb-phy-qcom-ipq4019 ipq-wifi-avm_fritzbox-4040 fritz-tffs fritz-caldata u-boot-fritz4040
-endef
-TARGET_DEVICES += avm_fritzbox-4040
-
 define Device/linksys_ea8500
        $(call Device/LegacyImage)
        DEVICE_DTS := qcom-ipq8064-ea8500
@@ -165,51 +150,6 @@ define Device/netgear_r7800
 endef
 TARGET_DEVICES += netgear_r7800
 
-define Device/openmesh_a42
-       $(call Device/FitImageLzma)
-       DEVICE_DTS := qcom-ipq4019-a42
-       KERNEL_LOADADDR := 0x80208000
-       BLOCKSIZE := 64k
-       SUPPORTED_DEVICES := openmesh,a42
-       DEVICE_TITLE := OpenMesh A42
-       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
-       IMAGE_SIZE := 15616k
-       IMAGES = factory.bin sysupgrade.bin
-       IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
-       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 uboot-envtools ipq-wifi-openmesh_a42
-endef
-TARGET_DEVICES += openmesh_a42
-
-define Device/qcom_ap-dk01.1-c1
-       DEVICE_TITLE := QCA AP-DK01.1-C1
-       BOARD_NAME := ap-dk01.1-c1
-       DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
-       KERNEL_LOADADDR := 0x80208000
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4096k
-       IMAGE_SIZE := 26624k
-       $(call Device/FitImage)
-       IMAGES := sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019
-endef
-TARGET_DEVICES += qcom_ap-dk01.1-c1
-
-define Device/qcom_ap-dk04.1-c1
-       $(call Device/FitImage)
-       $(call Device/UbiFit)
-       DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
-       KERNEL_LOADADDR := 0x80208000
-       KERNEL_INSTALL := 1
-       KERNEL_SIZE := 4048k
-       BLOCKSIZE := 128k
-       PAGESIZE := 2048
-       BOARD_NAME := ap-dk04.1-c1
-       DEVICE_TITLE := QCA AP-DK04.1-C1
-endef
-TARGET_DEVICES += qcom_ap-dk04.1-c1
-
 define Device/qcom_ipq8064-ap148
        $(call Device/FitImage)
        $(call Device/UbiFit)