kernel: refresh patches for 2.6.33.2, and drop md5sum for older 2.6.32 kernels
[openwrt/staging/chunkeey.git] / target / linux / ixp4xx / patches-2.6.33 / 520-tw2662_support.patch
index b26016ca592f502cd94f31adc442d8c6865a22c3..cc796c504b11a2ad855668636405ee7115ca8bf6 100644 (file)
@@ -1,6 +1,6 @@
---- a/arch/arm/mach-ixp4xx/Kconfig     
+--- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -180,6 +180,15 @@
+@@ -180,6 +180,15 @@ config ARCH_PRPMC1100
          PrPCM1100 Processor Mezanine Module. For more information on
          this platform, see <file:Documentation/arm/IXP4xx>.
  
@@ -18,7 +18,7 @@
        select PCI
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -23,6 +23,7 @@
+@@ -23,6 +23,7 @@ obj-pci-$(CONFIG_MACH_SIDEWINDER)    += sid
  obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
  obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
  obj-pci-$(CONFIG_MACH_AP1000)         += ixdp425-pci.o
@@ -26,7 +26,7 @@
  obj-pci-$(CONFIG_MACH_TW5334)         += tw5334-pci.o
  obj-pci-$(CONFIG_MACH_MI424WR)                += mi424wr-pci.o
  obj-pci-$(CONFIG_MACH_USR8200)                += usr8200-pci.o
-@@ -48,6 +49,7 @@
+@@ -48,6 +49,7 @@ obj-$(CONFIG_MACH_SIDEWINDER)        += sidewin
  obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
  obj-$(CONFIG_MACH_AP1000)     += ap1000-setup.o
@@ -36,7 +36,7 @@
  obj-$(CONFIG_MACH_USR8200)    += usr8200-setup.o
 --- a/arch/arm/mach-ixp4xx/include/mach/uncompress.h
 +++ b/arch/arm/mach-ixp4xx/include/mach/uncompress.h
-@@ -43,7 +43,7 @@
+@@ -43,7 +43,7 @@ static __inline__ void __arch_decomp_set
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
                         machine_is_gateway7001() || machine_is_wg302v2() ||
                         machine_is_pronghorn() || machine_is_pronghorn_metro() || machine_is_wrt300nv2() ||
@@ -45,7 +45,7 @@
                uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
        else
                uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;
---- a/arch/arm/mach-ixp4xx/tw2662-pci.c
+--- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw2662-pci.c
 @@ -0,0 +1,68 @@
 +/*
 +}
 +
 +subsys_initcall(tw2662_pci_init);
---- a/arch/arm/mach-ixp4xx/tw2662-setup.c
+--- /dev/null
 +++ b/arch/arm/mach-ixp4xx/tw2662-setup.c
 @@ -0,0 +1,208 @@
 +/*