add a patch to export dma_set_coherent_mask
[openwrt/staging/chunkeey.git] / target / linux / ixp4xx / patches-2.6.34 / 295-latch_led_driver.patch
index 64be0c3091e7ae56d7c71f7ef5a26e3e1d2c1d2d..af4eadaee87d668b9ba9bd50198013a81daeffc8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -157,6 +157,13 @@ config LEDS_LP3944
+@@ -166,6 +166,13 @@ config LEDS_LP3944
          To compile this driver as a module, choose M here: the
          module will be called leds-lp3944.
  
          To compile this driver as a module, choose M here: the
          module will be called leds-lp3944.
  
 +
  config LEDS_CLEVO_MAIL
        tristate "Mail LED on Clevo notebook"
 +
  config LEDS_CLEVO_MAIL
        tristate "Mail LED on Clevo notebook"
-       depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI
+       depends on X86 && SERIO_I8042 && DMI
 --- /dev/null
 +++ b/drivers/leds/leds-latch.c
 --- /dev/null
 +++ b/drivers/leds/leds-latch.c
-@@ -0,0 +1,149 @@
+@@ -0,0 +1,150 @@
 +/*
 + * LEDs driver for Memory Latched Devices
 + *
 +/*
 + * LEDs driver for Memory Latched Devices
 + *
@@ -35,6 +35,7 @@
 +#include <linux/workqueue.h>
 +#include <asm/io.h>
 +#include <linux/spinlock.h>
 +#include <linux/workqueue.h>
 +#include <asm/io.h>
 +#include <linux/spinlock.h>
++#include <linux/slab.h>
 +
 +static unsigned int mem_keep = 0xFF;
 +static spinlock_t mem_lock;
 +
 +static unsigned int mem_keep = 0xFF;
 +static spinlock_t mem_lock;
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
+@@ -21,6 +21,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
  obj-$(CONFIG_LEDS_SUNFIRE)            += leds-sunfire.o
  obj-$(CONFIG_LEDS_PCA9532)            += leds-pca9532.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o
  obj-$(CONFIG_LEDS_SUNFIRE)            += leds-sunfire.o
  obj-$(CONFIG_LEDS_PCA9532)            += leds-pca9532.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o