kirkwood: add support for Linksys EA3500
[openwrt/staging/chunkeey.git] / target / linux / kirkwood / profiles / 115-router.mk
index 000aa7418f62efac81bdd88a20e0e04e751a1234..ef7f228d2c4d8d80cff4b61e06899f8114826c4a 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define Profile/EA3500
+  NAME:=Linksys EA3500
+  PACKAGES:= \
+       kmod-mwl8k kmod-usb2 kmod-usb-storage \
+       uboot-envtools
+endef
+
+define Profile/EA3500/Description
+ Package set compatible with Linksys EA3500 board.
+endef
+
+EA3500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+EA3500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,EA3500))
+
 define Profile/EA4500
   NAME:=Linksys EA4500
   PACKAGES:= \