lantiq: add Falcon support
[openwrt/staging/chunkeey.git] / target / linux / lantiq / Makefile
index 98245e827c4730dcbdaa86c8b794e40b4f9953e1..66f3e7645d71e8d63b92abd17f62fb2d732bdd8a 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC