update lantiq/falcon patches
[openwrt/staging/chunkeey.git] / target / linux / lantiq / image / Makefile
index bfd73f6dd53582360dcdf2c3da605618195e1595..b1ef0a5cde623325c107d7ab5fe9223e33ede18a 100644 (file)
@@ -9,8 +9,9 @@ include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE = 64k 128k 256k
 
-xway_cmdline=-console=ttyS1,115200 rootfstype=squashfs,jffs2
-falcon_cmdline=-console=ttyS0,115200 rootfstype=squashfs,jffs2
+ase_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
+xway_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
+falcon_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
 
 define CompressLzma
   $(STAGING_DIR_HOST)/bin/lzma e $(1) $(2)
@@ -135,6 +136,22 @@ define Image/Build/Profile/ARV752DPW22
        $(call Image/Build/$(1),$(1),ARV752DPW22)
 endef
 
+define Image/BuildKernel/Profile/DGN3500B
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+       $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
+define Image/BuildKernel/Profile/GIGASX76X
+       $(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/GIGASX76X
+       $(call Image/Build/$(1),$(1),GIGASX76X)
+endef
+
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
        $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
@@ -148,6 +165,8 @@ define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
        $(call Image/BuildKernel/Template,NONE)
 endef
 
@@ -164,12 +183,14 @@ define Image/Build/Profile/Generic
        $(call Image/Build/$(1),$(1),ARV7518PW)
        $(call Image/Build/$(1),$(1),ARV752DPW)
        $(call Image/Build/$(1),$(1),ARV752DPW22)
+       $(call Image/Build/$(1),$(1),GIGASX76X)
+       $(call Image/Build/$(1),$(1),DGN3500B)
        $(call Image/Build/$(1),$(1),NONE)
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
 endef
 endif
 
-ifeq ($(CONFIG_TARGET_lantiq_falcon),y)
+ifeq ($(CONFIG_TARGET_lantiq_falcon)$(CONFIG_TARGET_lantiq_falcon_stable),y)
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
        $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))
@@ -184,6 +205,27 @@ define Image/Build/Profile/Generic
 endef
 endif
 
+ifeq ($(CONFIG_TARGET_lantiq_ase),y)
+define Image/BuildKernel/Profile/EASY50601
+       $(call Image/BuildKernel/Template,EASY50601,$(ase_cmdline))
+endef
+
+define Image/Build/Profile/EASY50601
+       $(call Image/Build/$(1),$(1),EASY50601)
+endef
+
+define Image/BuildKernel/Profile/Generic
+       $(call Image/BuildKernel/Template,EASY50601,$(ase_cmdline))
+       $(call Image/BuildKernel/Template,NONE)
+endef
+
+define Image/Build/Profile/Generic
+       $(call Image/Build/$(1),$(1),EASY50601)
+       $(call Image/Build/$(1),$(1),NONE)
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+endef
+endif
+
 define Image/BuildKernel
        $(call Image/BuildKernel/Profile/$(PROFILE))
 endef