target: mpc85xx: switch to kernel 4.9
[openwrt/staging/chunkeey.git] / target / linux / mpc85xx / Makefile
index 37669684db1c5005a7d5d2846ffce7b3233ab8a6..8428bec6bc0d64e5d5631440a03a114bf9cf53bd 100644 (file)
@@ -10,21 +10,25 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=spe_fpu squashfs
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=4.9
+
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))