target: mpc85xx: refresh kernel patches
[openwrt/staging/chunkeey.git] / target / linux / mpc85xx / patches-4.9 / 100-powerpc-85xx-tl-wdr4900-v1-support.patch
index e657ee514a9b283bd8a395f633de3165985c783a..f11f4d6e7d04d64e656332d69ba41ca9f1e97bdc 100644 (file)
@@ -17,25 +17,25 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -114,6 +114,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -137,6 +137,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
- src-plat-$(CONFIG_PPC_CELL_QPACE) += pseries-head.S
+ src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
 +src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
  
  src-wlib := $(sort $(src-wlib-y))
  src-plat := $(sort $(src-plat-y))
-@@ -297,6 +298,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
+@@ -320,6 +321,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_SBC8548)                       += cuImage.sbc8548
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
 +image-$(CONFIG_TL_WDR4900_V1)         += cuImage.tl-wdr4900-v1
  
- # Board ports in arch/powerpc/platform/embedded6xx/Kconfig
- image-$(CONFIG_STORCENTER)            += cuImage.storcenter
+ # Board ports in arch/powerpc/platform/86xx/Kconfig
+ image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -235,6 +235,10 @@ cuboot*)
+@@ -277,6 +277,10 @@ cuboot*)
      *-mpc85*|*-tqm85*|*-sbc85*)
          platformo=$object/cuboot-85xx.o
          ;;
@@ -48,7 +48,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
          ;;
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -168,6 +168,17 @@ config STX_GP3
+@@ -169,6 +169,17 @@ config STX_GP3
        select CPM2
        select DEFAULT_UIMAGE
  
@@ -68,7 +68,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
        help
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
+@@ -24,6 +24,7 @@ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
  obj-$(CONFIG_STX_GP3)   += stx_gp3.o
  obj-$(CONFIG_TQM85xx)   += tqm85xx.o