ramips: check size after padding
[openwrt/staging/chunkeey.git] / target / linux / ramips / image / Makefile
index b0b35796a7b8fcfe32b4338a06a112db04546894..422366c09855609adb0a3d0b8408a54c984d3f79 100644 (file)
@@ -35,7 +35,7 @@ define Device/Default
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | check-size $$$$(IMAGE_SIZE) | pad-rootfs
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Build/patch-dtb