ramips: drop rt-n56u factory image
[openwrt/staging/chunkeey.git] / target / linux / ramips / image / rt3883.mk
index abece505d7e7efdf05a785cab8974391b02c5e74..973eab9a64901c8320707de09521729251d20932 100644 (file)
@@ -1,6 +1,9 @@
 #
 # RT3662/RT3883 Profiles
 #
+define Build/mkrtn56uimg
+       $(STAGING_DIR_HOST)/bin/mkrtn56uimg $(1) $@
+endef
 
 define Device/br-6475nd
   DTS := BR-6475ND
@@ -66,6 +69,17 @@ endef
 TARGET_DEVICES += hpm
 
 
+define Device/rt-n56u
+  DTS := RT-N56U
+  BLOCKSIZE := 64k
+  IMAGES += factory.bin
+  IMAGE/sysupgrade.bin += | mkrtn56uimg -s
+  DEVICE_TITLE := Asus RT-N56U
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+TARGET_DEVICES += rt-n56u
+
+
 define Device/tew-691gr
   DTS := TEW-691GR
   BLOCKSIZE := 64k