build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt/staging/chunkeey.git] / target / linux / rdc-2.6 / Makefile
index 616a7e4855d5c305f0bfa2d7e554e06703d380c2..5953e06ee63e13760d5d7c3f2c86b2dbc2cc9466 100644 (file)
@@ -9,15 +9,27 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=broken squashfs jffs2
+FEATURES:=squashfs jffs2 broken
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
         Build firmware images for RDC3211 based routers
-        (e.g. Airlink101 AR525W)
+        (e.g. Airlink101 AR525W, Linksys WRT54R)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-KERNEL_MAKEOPTS += CFLAGS_KERNEL="-DRDC3210_NVRAM_IS_JFFS2=1"
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Kernel/SetInitramfs
+       echo "r6040 parent=wlan0" > $(BUILD_DIR)/root/etc/modules.d/99-r6040
+       rm -f $(BUILD_DIR)/root/sbin/init
+       ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
+       sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(BUILD_DIR)/root/etc/preinit
+       sed -i 's,/sbin/init,/bin/busybox init,g' $(BUILD_DIR)/root/init
+       sed -i 's,eth0,eth1,g' $(BUILD_DIR)/root/etc/config/network
+    endef
+endif
 
 # include the profiles
 -include profiles/*.mk