Remove initrd code leftovers. Also fixes "Bad page state" on boot (kernel tried to...
[openwrt/staging/chunkeey.git] / target / linux / x86-2.6 / Makefile
index 5dc19cf679161e43c9f3f86f2112a6146a6a891b..ff52093ef3c19f46ac13876ed89229abfe9fa0b3 100644 (file)
@@ -6,15 +6,16 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH=i386
+BOARD:=x86
+BOARDNAME:=x86
+FEATURES:=squashfs jffs2 ext2
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@