switch from ext2 to ext4 (w/o) journaling
[openwrt/staging/chunkeey.git] / target / linux / x86 / Makefile
index f4b2763aeeba1bd7c153f1866fa7a620df59cc66..5ff1d246fb246aca4931afae8dd25f9c35b9ef0b 100644 (file)
@@ -1,21 +1,20 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic mediacenter
+FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.23.12
+LINUX_VERSION:=2.6.36
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))