add a binutils variant based on a binutils snapshot and codesourcery g++ enhancements...
[openwrt/staging/chunkeey.git] / toolchain / binutils / Makefile
index c9da2cfd78868da6c6e46f91b7862b557a9b73d4..7073507dee81d76a4ce772a4012d19af22944409 100644 (file)
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
 PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
+BIN_VERSION:=$(PKG_VERSION)
 
 PKG_SOURCE_URL:=@GNU/binutils/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,6 +19,13 @@ endif
 ifeq ($(PKG_VERSION),2.19.1)
   PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
 endif
+ifeq ($(PKG_VERSION),2.19.1+cs)
+  BIN_VERSION:=20090205
+  PKG_SOURCE:=$(PKG_NAME)-$(BIN_VERSION).tar.bz2
+  PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+  PKG_MD5SUM:=040740e8c864dd1a15886753f9c0bc0b
+  HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/binutils-$(BIN_VERSION)
+endif
 
 PATCH_DIR:=./patches/$(PKG_VERSION)