add binutils 2.20
[openwrt/staging/chunkeey.git] / toolchain / binutils / Makefile
index 10902df5c47b9242a3d3373803df11f3dcd15581..d24151db2a70a2430800034f05407802db8a7e3e 100644 (file)
@@ -8,22 +8,27 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
 PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
+BIN_VERSION:=$(PKG_VERSION)
 
 PKG_SOURCE_URL:=@GNU/binutils/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-ifeq ($(PKG_VERSION),2.17)
-  PKG_MD5SUM:=e26e2e06b6e4bf3acf1dc8688a94c0d1
-endif
 ifeq ($(PKG_VERSION),2.18)
   PKG_MD5SUM:=9d22ee4dafa3a194457caf4706f9cf01
 endif
-ifeq ($(PKG_VERSION),2.19)
-  PKG_MD5SUM:=17a52219dee5a76c1a9d9b0bfd337d66
-endif
 ifeq ($(PKG_VERSION),2.19.1)
   PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
 endif
+ifeq ($(PKG_VERSION),2.19.1+cs)
+  BIN_VERSION:=20090205
+  PKG_SOURCE:=$(PKG_NAME)-$(BIN_VERSION).tar.bz2
+  PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+  PKG_MD5SUM:=040740e8c864dd1a15886753f9c0bc0b
+  HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/binutils-$(BIN_VERSION)
+endif
+ifeq ($(PKG_VERSION),2.20)
+  PKG_MD5SUM:=ee2d3e996e9a2d669808713360fa96f8
+endif
 
 PATCH_DIR:=./patches/$(PKG_VERSION)