cleanup toolchain version handling
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
index 07f050a..019cd16 100644 (file)
@@ -2,44 +2,51 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_VERSION_3_4_6 if LINUX_2_4
-       default GCC_VERSION_4_2_4 if TARGET_avr32
-       default GCC_VERSION_4_2_4 if TARGET_ppc40x
-       default GCC_VERSION_4_2_4 if TARGET_ppc44x
-       default GCC_VERSION_4_3_3 if powerpc64
-       default GCC_VERSION_4_3_3 if TARGET_etrax
-       default GCC_VERSION_4_3_3 if TARGET_coldfire
-       default GCC_VERSION_4_4_0 if ubicom32
-       default GCC_VERSION_4_4_1 if TARGET_octeon
-       default GCC_VERSION_4_1_2
+       default GCC_VERSION_4_3_5 if (avr32 || powerpc64)
+       default GCC_VERSION_4_3_5 if (TARGET_coldfire || TARGET_etrax || TARGET_gemini || TARGET_cns21xx)
+       default GCC_VERSION_4_3_3_CS if (arm || armeb) && !(TARGET_gemini || TARGET_cns21xx || TARGET_omap35xx)
+       default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
+       default GCC_VERSION_4_4_5 if (powerpc || ubicom32)
+       default GCC_VERSION_4_4_5 if (TARGET_omap35xx || TARGET_octeon || TARGET_sibyte)
+       default GCC_VERSION_4_5_1_LINARO
        help
          Select the version of gcc you wish to use.
 
-       config GCC_VERSION_3_4_6
-               bool "gcc 3.4.6"
+       config GCC_VERSION_4_3_5
+               bool "gcc 4.3.5"
 
-if !LINUX_2_4
-       config GCC_VERSION_4_1_2
-               bool "gcc 4.1.2"
+       config GCC_VERSION_4_4_5
+               bool "gcc 4.4.5"
 
-       config GCC_VERSION_4_2_4
-               bool "gcc 4.2.4"
+       config GCC_VERSION_4_5_2
+               bool "gcc 4.5.2"
 
-       config GCC_VERSION_4_3_3
-               bool "gcc 4.3.3"
+       config GCC_VERSION_4_5_1_LINARO
+               bool "gcc 4.5.1 with Linaro enhancements"
 
-       config GCC_VERSION_4_3_4
-               bool "gcc 4.3.4"
+       config GCC_VERSION_LLVM
+               bool "llvm-gcc 4.2"
+               depends BROKEN
 
-       config GCC_VERSION_4_4_0
-               bool "gcc 4.4.0"
+       config GCC_VERSION_4_3_3_CS
+               bool "gcc 4.3.3 with CodeSourcery enhancements"
 
-       config GCC_VERSION_4_4_1
-               bool "gcc 4.4.1"
-endif
+       config GCC_VERSION_4_4_1_CS
+               bool "gcc 4.4.1 with CodeSourcery enhancements"
 
 endchoice
 
+config GCC_USE_GRAPHITE
+       bool
+       prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
+       depends GCC_VERSION_4_4 || GCC_VERSION_4_5
+
+config GCC_USE_SYSTEM_PPL_CLOOG
+       bool
+       prompt "Use the system versions of PPL and CLooG"
+       depends GCC_USE_GRAPHITE
+       default n
+
 config EXTRA_GCC_CONFIG_OPTIONS
        string
        prompt "Additional gcc configure options" if TOOLCHAINOPTS
@@ -49,12 +56,19 @@ config EXTRA_GCC_CONFIG_OPTIONS
 
 config SSP_SUPPORT
        bool
-       depends !GCC_VERSION_3_4_6
        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
        default n
        help
            Enable Stack-Smashing Protection support
 
+config TLS_SUPPORT
+       bool
+       depends UCLIBC_VERSION_NPTL
+       prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
+       default n
+       help
+           Enable Thread-local storage support
+
 config INSTALL_LIBSTDCPP
        bool
        prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
@@ -64,6 +78,7 @@ config INSTALL_LIBSTDCPP
 
 config INSTALL_LIBGCJ
        bool
+       depends on !GCC_VERSION_LLVM
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
        default n
        help