tools: add isl (used for graphite on GCC 5)
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
index 5cb4d23..249a01b 100644 (file)
@@ -2,23 +2,26 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_USE_VERSION_4_6_LINARO if TARGET_octeon
+       default GCC_USE_VERSION_5 if TARGET_octeon
+       default GCC_USE_VERSION_4_8_ARC if arc
        default GCC_USE_VERSION_4_8_LINARO
        help
          Select the version of gcc you wish to use.
 
-       config GCC_USE_VERSION_4_6_LINARO
-               select GCC_VERSION_4_6_LINARO
-               bool "gcc 4.6.x with Linaro enhancements"
-
        config GCC_USE_VERSION_4_8_LINARO
                select GCC_VERSION_4_8_LINARO
                bool "gcc 4.8.x with Linaro enhancements"
+               depends on !arc
+
+       config GCC_USE_VERSION_4_8_ARC
+               select GCC_VERSION_4_8_ARC
+               bool "gcc 4.8.x with support of ARC cores"
+               depends on arc
 
-       config GCC_USE_VERSION_4_9_LINARO
-               select GCC_VERSION_4_9_LINARO
-               bool "gcc 4.9.x with Linaro enhancements"
-               depends on BROKEN
+       config GCC_USE_VERSION_5
+               select GCC_VERSION_5
+               bool "gcc 5.x"
+               depends on !arc
 
 endchoice
 
@@ -29,7 +32,7 @@ config GCC_USE_GRAPHITE
 config GCC_USE_SYSTEM_PPL_CLOOG
        bool
        prompt "Use the system versions of PPL and CLooG"
-       depends on GCC_USE_GRAPHITE
+       depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
        default n
 
 config EXTRA_GCC_CONFIG_OPTIONS
@@ -42,7 +45,8 @@ config EXTRA_GCC_CONFIG_OPTIONS
 config SSP_SUPPORT
        bool
        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
-       default y
+       depends on !USE_MUSL
+       default y if !USE_MUSL
        help
            Enable Stack-Smashing Protection support