tools: add isl (used for graphite on GCC 5)
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
index 9e6d0ed..249a01b 100644 (file)
@@ -2,46 +2,37 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_VERSION_4_3_3_CS if GCC_DEFAULT_VERSION_4_3_3_CS
-       default GCC_VERSION_4_3_5 if GCC_DEFAULT_VERSION_4_3_5
-       default GCC_VERSION_4_4_5 if GCC_DEFAULT_VERSION_4_4_5
-       default GCC_VERSION_LINARO
+       default GCC_USE_VERSION_5 if TARGET_octeon
+       default GCC_USE_VERSION_4_8_ARC if arc
+       default GCC_USE_VERSION_4_8_LINARO
        help
          Select the version of gcc you wish to use.
 
-       config GCC_VERSION_4_3_5
-               bool "gcc 4.3.5"
+       config GCC_USE_VERSION_4_8_LINARO
+               select GCC_VERSION_4_8_LINARO
+               bool "gcc 4.8.x with Linaro enhancements"
+               depends on !arc
 
-       config GCC_VERSION_4_4_5
-               bool "gcc 4.4.5"
+       config GCC_USE_VERSION_4_8_ARC
+               select GCC_VERSION_4_8_ARC
+               bool "gcc 4.8.x with support of ARC cores"
+               depends on arc
 
-       config GCC_VERSION_4_6_1
-               bool "gcc 4.6.1"
-
-       config GCC_VERSION_LINARO
-               bool "gcc 4.5.x with Linaro enhancements"
-
-       config GCC_VERSION_LLVM
-               bool "llvm-gcc 4.2"
-               depends BROKEN
-
-       config GCC_VERSION_4_3_3_CS
-               bool "gcc 4.3.3 with CodeSourcery enhancements"
-
-       config GCC_VERSION_4_4_1_CS
-               bool "gcc 4.4.1 with CodeSourcery enhancements"
+       config GCC_USE_VERSION_5
+               select GCC_VERSION_5
+               bool "gcc 5.x"
+               depends on !arc
 
 endchoice
 
 config GCC_USE_GRAPHITE
        bool
        prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-       depends GCC_VERSION_4_4 || GCC_VERSION_4_5 || GCC_VERSION_4_6
 
 config GCC_USE_SYSTEM_PPL_CLOOG
        bool
        prompt "Use the system versions of PPL and CLooG"
-       depends GCC_USE_GRAPHITE
+       depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
        default n
 
 config EXTRA_GCC_CONFIG_OPTIONS
@@ -54,18 +45,11 @@ config EXTRA_GCC_CONFIG_OPTIONS
 config SSP_SUPPORT
        bool
        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
-       default n
+       depends on !USE_MUSL
+       default y if !USE_MUSL
        help
            Enable Stack-Smashing Protection support
 
-config TLS_SUPPORT
-       bool
-       depends UCLIBC_VERSION_NPTL
-       prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
-       default n
-       help
-           Enable Thread-local storage support
-
 config SJLJ_EXCEPTIONS
        bool
        prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
@@ -75,16 +59,8 @@ config SJLJ_EXCEPTIONS
            frame unwinding exceptions handling routines.  Warning: increases
            code size and runtime memory usage.
 
-config INSTALL_LIBSTDCPP
-       bool
-       prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
-       default y
-       help
-           Build/install c++ compiler and libstdc++?
-
 config INSTALL_LIBGCJ
        bool
-       depends on !GCC_VERSION_LLVM
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
        default n
        help