tools: add isl (used for graphite on GCC 5)
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
index ccaccaf..249a01b 100644 (file)
@@ -2,58 +2,38 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_VERSION_3_4_6 if LINUX_2_4
-       default GCC_VERSION_4_2_4 if TARGET_avr32
-       default GCC_VERSION_4_2_4 if TARGET_ppc40x
-       default GCC_VERSION_4_2_4 if TARGET_ppc44x
-       default GCC_VERSION_4_3_3 if powerpc64
-       default GCC_VERSION_4_3_3 if TARGET_etrax
-       default GCC_VERSION_4_3_3 if TARGET_coldfire
-       default GCC_VERSION_4_4_1 if ubicom32
-       default GCC_VERSION_4_4_1 if TARGET_octeon
-       default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !TARGET_octeon
-       default GCC_VERSION_4_3_3_CS if arm || armeb
-       default GCC_VERSION_4_1_2
+       default GCC_USE_VERSION_5 if TARGET_octeon
+       default GCC_USE_VERSION_4_8_ARC if arc
+       default GCC_USE_VERSION_4_8_LINARO
        help
          Select the version of gcc you wish to use.
 
-       config GCC_VERSION_3_4_6
-               bool "gcc 3.4.6"
+       config GCC_USE_VERSION_4_8_LINARO
+               select GCC_VERSION_4_8_LINARO
+               bool "gcc 4.8.x with Linaro enhancements"
+               depends on !arc
 
-if !LINUX_2_4
-       config GCC_VERSION_4_1_2
-               bool "gcc 4.1.2"
+       config GCC_USE_VERSION_4_8_ARC
+               select GCC_VERSION_4_8_ARC
+               bool "gcc 4.8.x with support of ARC cores"
+               depends on arc
 
-       config GCC_VERSION_4_2_4
-               bool "gcc 4.2.4"
-
-       config GCC_VERSION_4_3_3
-               bool "gcc 4.3.3"
-
-       config GCC_VERSION_4_3_4
-               bool "gcc 4.3.4"
-
-       config GCC_VERSION_4_4_1
-               bool "gcc 4.4.1"
-
-       config GCC_VERSION_4_4_2
-               bool "gcc 4.4.2"
-
-       config GCC_VERSION_LLVM
-               bool "llvm-gcc 4.2"
-               depends BROKEN
-
-       config GCC_VERSION_4_3_3_CS
-               bool "gcc 4.3.3 with CodeSourcery enhancements"
-
-endif
+       config GCC_USE_VERSION_5
+               select GCC_VERSION_5
+               bool "gcc 5.x"
+               depends on !arc
 
 endchoice
 
 config GCC_USE_GRAPHITE
        bool
        prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
-       depends GCC_VERSION_4_4_1 || GCC_VERSION_4_4_2
+
+config GCC_USE_SYSTEM_PPL_CLOOG
+       bool
+       prompt "Use the system versions of PPL and CLooG"
+       depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
+       default n
 
 config EXTRA_GCC_CONFIG_OPTIONS
        string
@@ -64,18 +44,20 @@ config EXTRA_GCC_CONFIG_OPTIONS
 
 config SSP_SUPPORT
        bool
-       depends !GCC_VERSION_3_4_6
        prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
-       default n
+       depends on !USE_MUSL
+       default y if !USE_MUSL
        help
            Enable Stack-Smashing Protection support
 
-config INSTALL_LIBSTDCPP
+config SJLJ_EXCEPTIONS
        bool
-       prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
-       default y
+       prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
+       default n
        help
-           Build/install c++ compiler and libstdc++?
+           Use old setjump()/longjump() exceptions instead of the newer
+           frame unwinding exceptions handling routines.  Warning: increases
+           code size and runtime memory usage.
 
 config INSTALL_LIBGCJ
        bool
@@ -83,3 +65,11 @@ config INSTALL_LIBGCJ
        default n
        help
            Build/install java compiler and GNU classpath ?
+
+
+config INSTALL_GFORTRAN
+       bool
+       prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
+       default n
+       help
+           Build/install GNU fortran compiler ?