cosmetic & coherency fixes
[openwrt/staging/chunkeey.git] / toolchain / gcc / Makefile
index 5e8bb9abb36b55cb827e6e87a1c31852bd167760..039643db9baa900488346af80c463037cd20baa0 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -35,6 +35,15 @@ endif
 ifeq ($(PKG_VERSION),4.2.4)
   PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
 endif
+ifeq ($(PKG_VERSION),4.3.1)
+  PKG_MD5SUM:=4afa0290cc3a41ac8822666f1110de98
+endif
+ifeq ($(PKG_VERSION),4.3.2)
+  PKG_MD5SUM:=5dfac5da961ecd5f227c3175859a486d
+endif
+ifeq ($(PKG_VERSION),4.3.3)
+  PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
+endif
 
 PATCH_DIR=./patches/$(PKG_VERSION)
 
@@ -54,7 +63,7 @@ PKG_BUILD_DIR2:=$(PKG_BUILD_DIR)-final
 SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
-GCC_CONFIGURE_COMMON:= \
+GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(PKG_BUILD_DIR)/configure \
                --prefix=$(TOOLCHAIN_DIR)/usr \
@@ -63,46 +72,54 @@ GCC_CONFIGURE_COMMON:= \
                --target=$(REAL_GNU_TARGET_NAME) \
                --with-gnu-ld \
                --enable-target-optspace \
+               --disable-libgomp \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
 
+ifneq ($(CONFIG_GCC_VERSION_4_3),)
+  GCC_BUILD_TARGET_LIBGCC:=y
+  GCC_CONFIGURE+= \
+               --with-gmp=$(TOPDIR)/staging_dir/host \
+               --with-mpfr=$(TOPDIR)/staging_dir/host \
+               --disable-decimal-float
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-libssp
 else
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --disable-libssp
 endif
 
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-biarch \
                --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
 ifeq ($(LIBC),uClibc)
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --disable-__cxa_atexit
 else
-       GCC_CONFIGURE_COMMON+= \
+  GCC_CONFIGURE+= \
                --enable-__cxa_atexit
 endif
 
 GCC_CONFIGURE_STAGE0:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --with-newlib \
                --without-headers \
                --enable-languages=c \
-               --disable-libgomp \
                --disable-libssp \
                --disable-shared \
                --disable-threads \
 
 GCC_CONFIGURE_STAGE1:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --with-newlib \
                --with-sysroot=$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
                --enable-languages=c \
@@ -110,7 +127,7 @@ GCC_CONFIGURE_STAGE1:= \
                --disable-threads \
 
 GCC_CONFIGURE_STAGE2:= \
-       $(GCC_CONFIGURE_COMMON) \
+       $(GCC_CONFIGURE) \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
@@ -151,11 +168,18 @@ define Stage1/Configure
 endef
 
 define Stage1/Compile
-       $(GCC_MAKE) -C $(PKG_BUILD_DIR1) all-build-libiberty all-gcc
+       $(CP) $(BUILD_DIR_TOOLCHAIN)/linux-dev/* $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/
+       $(GCC_MAKE) -C $(PKG_BUILD_DIR1) \
+               all-build-libiberty \
+               all-gcc \
+               $(if $(GCC_BUILD_TARGET_LIBGCC),all-target-libgcc)
 endef
 
 define Stage1/Install
-       $(GCC_MAKE) -C $(PKG_BUILD_DIR1) install-gcc
+       $(GCC_MAKE) -C $(PKG_BUILD_DIR1) \
+               install-gcc \
+               $(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)
+       
        # XXX: glibc insists on linking against libgcc_eh
        ( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
                [ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \