gcc: enable LTO support unconditionally
[openwrt/staging/chunkeey.git] / toolchain / gcc / final / Makefile
index 1212d145abd8bdf3a22fbf6a68d5d05dadeb81b4..3434d894a2b501ba9545c99d47066fc43a7b5480 100644 (file)
@@ -8,13 +8,9 @@ GCC_CONFIGURE += \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
-       --with-slibdir=$(TOOLCHAIN_DIR)/lib
-
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
-  GCC_CONFIGURE += \
+       --with-slibdir=$(TOOLCHAIN_DIR)/lib \
        --enable-lto \
        --with-libelf=$(TOPDIR)/staging_dir/host
-endif
 
 ifdef CONFIG_USE_MUSL
   GCC_MAKE += gcc_cv_libc_provides_ssp=yes