toolchain: add support of ARCv2 architecture
[openwrt/staging/chunkeey.git] / toolchain / gcc / final / Makefile
index 3fb5ccf83fe63466617c6045001284c0af354155..3434d894a2b501ba9545c99d47066fc43a7b5480 100644 (file)
@@ -8,12 +8,12 @@ GCC_CONFIGURE += \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
-       --with-slibdir=$(TOOLCHAIN_DIR)/lib
-
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
-  GCC_CONFIGURE += \
+       --with-slibdir=$(TOOLCHAIN_DIR)/lib \
        --enable-lto \
        --with-libelf=$(TOPDIR)/staging_dir/host
+
+ifdef CONFIG_USE_MUSL
+  GCC_MAKE += gcc_cv_libc_provides_ssp=yes
 endif
 
 ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)