gdb: update to 7.5-2012.09
[openwrt/staging/chunkeey.git] / toolchain / gdb / Makefile
index 40fc2789b6d081508dfff2a4cfdc53c4c4285612..89f73ef49e2834473f818313d3f4d0eb23625f11 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,48 +7,48 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.3
+PKG_REV:=7.5-2012.09
+PKG_VERSION_MAJOR:=7.5
+PKG_VERSION:=linaro-$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
+PKG_MD5SUM:=758c2da97c27f7b50ca48cb803eaa9aa
+PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
 
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
-BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+HOST_BUILD_PARALLEL:=1
 
-include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/toolchain-build.mk
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); \
                gdb_cv_func_sigsetjmp=yes \
-               $(PKG_BUILD_DIR)/configure \
+               CFLAGS="-O2" \
+               $(HOST_BUILD_DIR)/configure \
                --prefix=$(TOOLCHAIN_DIR) \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
+               --disable-werror \
                $(DISABLE_NLS) \
-               --without-uiout --disable-gdbmi \
+               --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
                --enable-threads \
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       strip $(PKG_BUILD_DIR)/gdb/gdb
-endef
-
-define Build/Install
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb
-       ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/$(GNU_TARGET_NAME)-gdb; \
+define Host/Install
+       mkdir -p $(TOOLCHAIN_DIR)/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+       ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+       strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
 endef
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
-       rm -f $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+define Host/Clean
+       rm -rf \
+               $(HOST_BUILD_DIR) \
+               $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb \
+               $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
 endef
 
 $(eval $(call HostBuild))