uClibc cleanup: - use full version string (0.9.30.1), instead of base (0.9.30) +...
[openwrt/staging/chunkeey.git] / toolchain / glibc / Makefile
index d014cacdedaf4e5dffa900d22c6300e85c9e886f..1f715b9d45103f6e6f4f4441b15c220a401ade83 100644 (file)
@@ -57,6 +57,7 @@ GLIBC_CONFIGURE:= \
                --build=$(GNU_HOST_NAME) \
                --host=$(REAL_GNU_TARGET_NAME) \
                --with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
                --disable-debug \
                --disable-profile \
                --enable-add-ons="$(GLIBC_ADD_ONS)" \
@@ -87,7 +88,7 @@ define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
-       $(SED) 's,^\(LIBC_PATCHVER\)=.*,\1=,' $(TOOLCHAIN_DIR)/info.mk
+       $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
 endef
 
 define Stage1/Configure