musl: move BUILD_DIR_TOOLCHAIN/musl symlink to configure step
[openwrt/staging/chunkeey.git] / toolchain / musl / common.mk
index 4b53d4b556c80149d854389434006bf4f41532cc..497aa8df0d8056b53c104e58a6197851760d5b54 100644 (file)
@@ -39,18 +39,8 @@ MUSL_CONFIGURE:= \
                --disable-gcc-wrapper \
                --enable-debug
 
-define Host/Prepare
-       $(call Host/Prepare/Default)
-       $(if $(strip $(QUILT)), \
-               cd $(HOST_BUILD_DIR); \
-               if $(QUILT_CMD) next >/dev/null 2>&1; then \
-                       $(QUILT_CMD) push -a; \
-               fi
-       )
-       ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
-endef
-
 define Host/Configure
+       ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        ( cd $(HOST_BUILD_DIR); rm -f config.cache; \
                $(MUSL_CONFIGURE) \
        );