bring in floorf so that postgres server will compile by default, package to come...
[openwrt/staging/chunkeey.git] / toolchain / uClibc / patches / 120-more_standard_math.patch
index f7d626ac034f22971811bece4e012cf975f6e7dd..cfb939105618e32748cafcdc754cf5991d889d21 100644 (file)
@@ -6,7 +6,7 @@ diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
         s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
         w_sinh.c w_sqrt.c s_tan.c s_tanh.c
 +# extra stuff required for some apps
-+CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
++CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c s_floorf.c
  CSRC+=   s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
         k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
         k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \