build: add CHECK_ALL variable to allow make download/check to include not selected...
[openwrt/staging/chunkeey.git] / tools / Makefile
index 6915ea7a05552dc73500f20a110fad8a6ddbb1f1..247f55776f81e4b4cfb9029623e23cd6e9ab23e2 100644 (file)
@@ -110,6 +110,11 @@ tools-y += flock
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
+endif
+
 ifndef DUMP_TARGET_DB
 define PrepareStaging
        @for dir in $(1); do ( \
 ifndef DUMP_TARGET_DB
 define PrepareStaging
        @for dir in $(1); do ( \