add a host package for xz
[openwrt/staging/chunkeey.git] / tools / Makefile
index 9a6cf964d9782bca69fed55e0ffe48cbfb7b270c..3b3f187c4d7bf1d78dc6e992f3c1818bbea4006a 100644 (file)
@@ -17,7 +17,7 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += xorg-macros
+tools-y += xorg-macros xz
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -47,7 +47,7 @@ $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
-$(curdir)/xorg-macros/compile := $(curdir)/autoconf/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -63,11 +63,8 @@ define PrepareStaging
 endef
 
 # preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(call PrepareStaging,$(STAGING_DIR))
-       mkdir -p $(STAGING_DIR)/host/share
-       rm -rf $(STAGING_DIR)/host/share/aclocal
-       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@