build: implement make check and make package/X/check
[openwrt/staging/chunkeey.git] / tools / Makefile
index 4bfe4af9072f7e84e9c0864f1a9c633d84462b20..6915ea7a05552dc73500f20a110fad8a6ddbb1f1 100644 (file)
@@ -145,4 +145,5 @@ $(curdir)//install = $(1)/compile
 
 tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))
 $(eval $(call stampfile,$(curdir),tools,install,,_$(subst $(space),,$(tools_enabled))))
+$(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build))
 $(eval $(call subdir,$(curdir)))