Makefile: Put lzma before squashfs so compile of squashfs4 succeeds (depends on lzma)
[openwrt/staging/chunkeey.git] / tools / Makefile
index 7f22591dcce5eed689a07b9d37407d7fa4e7c92f..ce405e7adb60ff4d7c5c2aef72e7073ce8f0a088 100644 (file)
@@ -17,13 +17,13 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += xorg-macros
+tools-y += xorg-macros xz
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
-tools-y += squashfs lzma-old
+tools-y += lzma-old squashfs 
 endif
-tools-y += squashfs4 lzma
+tools-y += lzma squashfs4
 tools-$(CONFIG_CCACHE) += ccache
 
 ifdef CONFIG_GCC_USE_GRAPHITE
@@ -63,7 +63,7 @@ define PrepareStaging
 endef
 
 # preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(call PrepareStaging,$(STAGING_DIR))
        mkdir -p $(BUILD_DIR)/stamp
        touch $@