tools/cmake: enable parallel builds
[openwrt/staging/chunkeey.git] / tools / cmake / Makefile
index dbc2a7e124c2ff9ce86b7c4e29c091a4eed74f3e..7ffcc1b1d25e4f185072fd48ef0b87aa335cccf8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=2.8.3
+PKG_VERSION:=2.8.7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
-PKG_MD5SUM:=a76a44b93acf5e3badda9de111385921
+PKG_MD5SUM:=e1b237aeaed880f65dec9c20602452f6
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
+
 $(eval $(call HostBuild))