tools/flex: disable building shared libfl.so
[openwrt/staging/chunkeey.git] / tools / flex / Makefile
index abb275db89b25d72e6ff3569103c2acfd00184f8..90082df43e013afbe10de792303779ec6534a10f 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,17 +7,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.37
+PKG_VERSION:=2.5.39
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=c75940e1fc25108f2a7b3ef42abdae06
+PKG_MD5SUM:=77d44c6bb8c0705e0017ab9a84a1502b
 PKG_CAT:=bzcat
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 PKG_CAT:=bzcat
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += --disable-shared
 HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean
 HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean