mkimage: update to 2014.07
[openwrt/staging/chunkeey.git] / tools / squashfs / Makefile
index 473c5265108e4815ace6ec940c1557686c9661c5..6dc27d6750451b4182a5863f28c1f167e45ce1fa 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,6 +20,8 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               CC="$(HOSTCC)" \
+               CXX="$(CXX) $(HOST_STATIC_LINKING)" \
                LZMAPATH=$(STAGING_DIR_HOST)/lib \
                mksquashfs-lzma unsquashfs-lzma 
 endef