build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt/staging/chunkeey.git] / tools / sstrip / Makefile
index 87f331214ad138d72f850d4a347fd815caafd7ca..38362a5f7c003be62e53ee8e72f0129bafb0054e 100644 (file)
@@ -5,27 +5,21 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host-build.mk
 
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
+PKG_NAME:=sstrip
 
-OS:=$(shell uname)
-ifeq ($(HOST_OS),Darwin)
-  CFLAGS += -I./include
-endif
-CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
+include $(INCLUDE_DIR)/host-build.mk
 
 define Build/Compile
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
 define Build/Install
-       mkdir -p $(STAGING_DIR)/bin
-       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
 define Build/Clean
-       rm -f $(STAGING_DIR)/bin/sstrip
+       rm -f $(STAGING_DIR_HOST)/bin/sstrip
 endef
 
 $(eval $(call HostBuild))