split out profile definitions from Makefiles
authorTim Yardley <lst@openwrt.org>
Fri, 2 Mar 2007 23:02:38 +0000 (23:02 +0000)
committerTim Yardley <lst@openwrt.org>
Fri, 2 Mar 2007 23:02:38 +0000 (23:02 +0000)
structure is as follows:
target/linux/<arch>/profiles/<profilename>.mk

These files are included by a blob match in the target Makefile

The files should be labeled based on their profile Name in the definition

SVN-Revision: 6468

29 files changed:
target/linux/ar7-2.4/Makefile
target/linux/ar7-2.4/profiles/AnnexA.mk [new file with mode: 0644]
target/linux/ar7-2.4/profiles/AnnexB.mk [new file with mode: 0644]
target/linux/ar7-2.4/profiles/None.mk [new file with mode: 0644]
target/linux/au1000-2.6/Makefile
target/linux/au1000-2.6/profiles/Atheros.mk [new file with mode: 0644]
target/linux/au1000-2.6/profiles/Broadcom.mk [new file with mode: 0644]
target/linux/au1000-2.6/profiles/Intel.mk [new file with mode: 0644]
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.4/profiles/Atheros.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/Broadcom.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/BroadcomMimo.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/None.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WL500G.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WL500GD.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WL500GP.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WL700GE.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WLHDD.mk [new file with mode: 0644]
target/linux/brcm-2.4/profiles/WRT54G3G.mk [new file with mode: 0644]
target/linux/brcm-2.6/Makefile
target/linux/brcm-2.6/profiles/Atheros.mk [new file with mode: 0644]
target/linux/brcm-2.6/profiles/None.mk [new file with mode: 0644]
target/linux/brcm-2.6/profiles/WGT634U.mk [new file with mode: 0644]
target/linux/brcm63xx-2.6/Makefile
target/linux/brcm63xx-2.6/profiles/Atheros.mk [new file with mode: 0644]
target/linux/brcm63xx-2.6/profiles/Broadcom.mk [new file with mode: 0644]
target/linux/brcm63xx-2.6/profiles/Ralink.mk [new file with mode: 0644]
target/linux/rdc-2.6/Makefile
target/linux/rdc-2.6/profiles/Ralink.mk [new file with mode: 0644]

index 970bb4bbdf7d26d919867daa94406fe8654c5286..87c2470205bedbdac4677cfac1130b5addbcd6ff 100644 (file)
@@ -20,22 +20,7 @@ KERNEL:=2.4
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-avalanche-cpmac
 
-define Profile/AnnexA
-  NAME:=ADSL Annex A (default)
-  PACKAGES:=kmod-sangam-atm-annex-a ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexA))
-
-define Profile/AnnexB
-  NAME:=ADSL Annex B
-  PACKAGES:=kmod-sangam-atm-annex-b ppp-mod-pppoa
-endef
-$(eval $(call Profile,AnnexB))
-
-define Profile/None
-  NAME:=No ADSL
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
diff --git a/target/linux/ar7-2.4/profiles/AnnexA.mk b/target/linux/ar7-2.4/profiles/AnnexA.mk
new file mode 100644 (file)
index 0000000..10847d3
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AnnexA
+  NAME:=ADSL Annex A (default)
+  PACKAGES:=kmod-sangam-atm-annex-a ppp-mod-pppoa
+endef
+$(eval $(call Profile,AnnexA))
+
diff --git a/target/linux/ar7-2.4/profiles/AnnexB.mk b/target/linux/ar7-2.4/profiles/AnnexB.mk
new file mode 100644 (file)
index 0000000..b4eb807
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AnnexB
+  NAME:=ADSL Annex B
+  PACKAGES:=kmod-sangam-atm-annex-b ppp-mod-pppoa
+endef
+$(eval $(call Profile,AnnexB))
+
diff --git a/target/linux/ar7-2.4/profiles/None.mk b/target/linux/ar7-2.4/profiles/None.mk
new file mode 100644 (file)
index 0000000..336cc4c
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No ADSL
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
+
index 25fc776129b40c34cf88eca6bfff5de144f48108..30259d55b75f3f7bc705618394943514519321c9 100644 (file)
@@ -25,23 +25,8 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Intel
-  NAME:=Intel IPW2200 WiFi
-  PACKAGES:=kmod-net-ipw2200
-endef
-$(eval $(call Profile,Intel))
-
-define Profile/Broadcom
-  NAME:=Broadcom BCM43xx WiFi
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
 
diff --git a/target/linux/au1000-2.6/profiles/Atheros.mk b/target/linux/au1000-2.6/profiles/Atheros.mk
new file mode 100644 (file)
index 0000000..ec6e175
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000-2.6/profiles/Broadcom.mk b/target/linux/au1000-2.6/profiles/Broadcom.mk
new file mode 100644 (file)
index 0000000..d7fb9cb
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+  NAME:=Broadcom BCM43xx WiFi
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/au1000-2.6/profiles/Intel.mk b/target/linux/au1000-2.6/profiles/Intel.mk
new file mode 100644 (file)
index 0000000..be112ee
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Intel
+  NAME:=Intel IPW2200 WiFi
+  PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
index 28ee7b92058c6de07d62bc6c8f5899d927bdd80b..3158d497afc4a0e6ad000f4d17bc49108c2199df 100644 (file)
@@ -21,106 +21,7 @@ KERNEL:=2.4
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
 
-define Profile/Broadcom
-  NAME:=Generic, Broadcom WiFi (default)
-  PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
-endef
-
-define Profile/Broadcom/Description
-       Default package set compatible with most BCM947xx hardware
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/BroadcomMimo
-  NAME:=Generic, Broadcom WiFi (MIMO)
-  PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
-endef
-
-define Profile/BroadcomMimo/Description
-       Default package set compatible with 802.11n (draft) hardware
-endef
-$(eval $(call Profile,BroadcomMimo))
-
-define Profile/Atheros
-  NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=Generic, No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
-
-define Profile/WRT54G3G
-  NAME:=Linksys WRT54G3G
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
-endef
-
-define Profile/WRT54G3G/Description
-       Package set optimized for the WRT54G3G with UMTS support
-endef
-$(eval $(call Profile,WRT54G3G))
-
-define Profile/WL500G
-  NAME:=ASUS WL-500g
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500G/Description
-       Package set optimized for the WL-500g with USB and parallel port support
-endef
-$(eval $(call Profile,WL500G))
-
-define Profile/WL500GD
-  NAME:=ASUS WL-500g Deluxe
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500GD/Description
-       Package set optimized for the WL-500g Deluxe with USB support
-endef
-$(eval $(call Profile,WL500GD))
-
-define Profile/WL500GP
-  NAME:=ASUS WL-500g Premium
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500GP/Description
-       Package set optimized for the WL-500g Premium with USB support
-endef
-$(eval $(call Profile,WL500GP))
-
-define Profile/WLHDD
-  NAME:=WL-HDD
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
-endef
-
-define Profile/WLHDD/Description
-       Package set optimized for the WL-HDD with USB and IDE support
-endef
-$(eval $(call Profile,WLHDD))
-
-define Profile/WL700GE
-  NAME:=WL-700gE
-  PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
-endef
-
-define Profile/WL700GE/Description
-       Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
-       and the utilities to create a new filesystem on the HDD
-endef
-$(eval $(call Profile,WL700GE))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
diff --git a/target/linux/brcm-2.4/profiles/Atheros.mk b/target/linux/brcm-2.4/profiles/Atheros.mk
new file mode 100644 (file)
index 0000000..d721abb
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Generic, Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm-2.4/profiles/Broadcom.mk b/target/linux/brcm-2.4/profiles/Broadcom.mk
new file mode 100644 (file)
index 0000000..4732bdf
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+  NAME:=Generic, Broadcom WiFi (default)
+  PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
+endef
+
+define Profile/Broadcom/Description
+       Default package set compatible with most BCM947xx hardware
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm-2.4/profiles/BroadcomMimo.mk b/target/linux/brcm-2.4/profiles/BroadcomMimo.mk
new file mode 100644 (file)
index 0000000..04ff79f
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BroadcomMimo
+  NAME:=Generic, Broadcom WiFi (MIMO)
+  PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
+endef
+
+define Profile/BroadcomMimo/Description
+       Default package set compatible with 802.11n (draft) hardware
+endef
+$(eval $(call Profile,BroadcomMimo))
+
diff --git a/target/linux/brcm-2.4/profiles/None.mk b/target/linux/brcm-2.4/profiles/None.mk
new file mode 100644 (file)
index 0000000..5bfea2f
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=Generic, No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/brcm-2.4/profiles/WL500G.mk b/target/linux/brcm-2.4/profiles/WL500G.mk
new file mode 100644 (file)
index 0000000..3e61853
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL500G
+  NAME:=ASUS WL-500g
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
+endef
+
+define Profile/WL500G/Description
+       Package set optimized for the WL-500g with USB and parallel port support
+endef
+$(eval $(call Profile,WL500G))
+
diff --git a/target/linux/brcm-2.4/profiles/WL500GD.mk b/target/linux/brcm-2.4/profiles/WL500GD.mk
new file mode 100644 (file)
index 0000000..84972a5
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL500GD
+  NAME:=ASUS WL-500g Deluxe
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
+endef
+
+define Profile/WL500GD/Description
+       Package set optimized for the WL-500g Deluxe with USB support
+endef
+$(eval $(call Profile,WL500GD))
+
diff --git a/target/linux/brcm-2.4/profiles/WL500GP.mk b/target/linux/brcm-2.4/profiles/WL500GP.mk
new file mode 100644 (file)
index 0000000..308d915
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL500GP
+  NAME:=ASUS WL-500g Premium
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
+endef
+
+define Profile/WL500GP/Description
+       Package set optimized for the WL-500g Premium with USB support
+endef
+$(eval $(call Profile,WL500GP))
+
diff --git a/target/linux/brcm-2.4/profiles/WL700GE.mk b/target/linux/brcm-2.4/profiles/WL700GE.mk
new file mode 100644 (file)
index 0000000..9037327
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL700GE
+  NAME:=WL-700gE
+  PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
+endef
+
+define Profile/WL700GE/Description
+       Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
+       and the utilities to create a new filesystem on the HDD
+endef
+$(eval $(call Profile,WL700GE))
+
+
diff --git a/target/linux/brcm-2.4/profiles/WLHDD.mk b/target/linux/brcm-2.4/profiles/WLHDD.mk
new file mode 100644 (file)
index 0000000..b599fd0
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WLHDD
+  NAME:=WL-HDD
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
+endef
+
+define Profile/WLHDD/Description
+       Package set optimized for the WL-HDD with USB and IDE support
+endef
+$(eval $(call Profile,WLHDD))
+
diff --git a/target/linux/brcm-2.4/profiles/WRT54G3G.mk b/target/linux/brcm-2.4/profiles/WRT54G3G.mk
new file mode 100644 (file)
index 0000000..1694fec
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRT54G3G
+  NAME:=Linksys WRT54G3G
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
+endef
+
+define Profile/WRT54G3G/Description
+       Package set optimized for the WRT54G3G with UMTS support
+endef
+$(eval $(call Profile,WRT54G3G))
+
index 8b135072c3bcbb7f2fa4c539edf766e4cee7ca6e..a34d2187ae5f756ba1b2d8b81616342c0e2565c8 100644 (file)
@@ -19,34 +19,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
 
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/WGT634U
-  NAME:=Netgear WGT634U
-  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/WGT634U/Description
-       Package set compatible with the Netgear WGT634U. Contains USB support
-endef
-$(eval $(call Profile,WGT634U))
-
-define Profile/None
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/None/Description
-       Package set without WiFi support
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
diff --git a/target/linux/brcm-2.6/profiles/Atheros.mk b/target/linux/brcm-2.6/profiles/Atheros.mk
new file mode 100644 (file)
index 0000000..0295868
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm-2.6/profiles/None.mk b/target/linux/brcm-2.6/profiles/None.mk
new file mode 100644 (file)
index 0000000..2fcfacd
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/brcm-2.6/profiles/WGT634U.mk b/target/linux/brcm-2.6/profiles/WGT634U.mk
new file mode 100644 (file)
index 0000000..2a81e3a
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+  NAME:=Netgear WGT634U
+  PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WGT634U/Description
+       Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
index b9fd03c9e7fcf10912c5f1d1463ff711772be0a1..81a40d93e6a878e3c00b9b0fc7852a1d999f14c8 100644 (file)
@@ -18,22 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/Atheros
-  NAME:=Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
diff --git a/target/linux/brcm63xx-2.6/profiles/Atheros.mk b/target/linux/brcm63xx-2.6/profiles/Atheros.mk
new file mode 100644 (file)
index 0000000..0295868
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm63xx-2.6/profiles/Broadcom.mk b/target/linux/brcm63xx-2.6/profiles/Broadcom.mk
new file mode 100644 (file)
index 0000000..5fe71bb
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-net-bcm43xx
+endef
+
+define Profile/Broadcom/Description
+       Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm63xx-2.6/profiles/Ralink.mk b/target/linux/brcm63xx-2.6/profiles/Ralink.mk
new file mode 100644 (file)
index 0000000..f4c435d
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+  NAME:=Ralink WiFi
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+
index f1f751eee6732ebee3317080743de74e6174dfff..306734b273355a2058635e41d91cf98b90c5a586 100644 (file)
@@ -18,10 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))
diff --git a/target/linux/rdc-2.6/profiles/Ralink.mk b/target/linux/rdc-2.6/profiles/Ralink.mk
new file mode 100644 (file)
index 0000000..f4c435d
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+  NAME:=Ralink WiFi
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+