build: add apend-uboot command
authorDavid Bauer <mail@david-bauer.net>
Tue, 15 May 2018 17:02:48 +0000 (19:02 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 24 May 2018 15:24:31 +0000 (17:24 +0200)
This commit adds an append-uboot command to append U-Boot from the
bin-directory.

Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 399495a952bf687d9c59226bddf4e73d3b42b30c)

include/image-commands.mk

index a8486553998e882ec46ce1434003fece3ce6118c..82ceacd80eaa0aa3f7a39f6c3d770d4c72070086 100644 (file)
@@ -186,6 +186,10 @@ define Build/append-ubi
        rm $@.tmp
 endef
 
+define Build/append-uboot
+       dd if=$(UBOOT_PATH) >> $@
+endef
+
 define Build/pad-to
        dd if=$@ of=$@.new bs=$(1) conv=sync
        mv $@.new $@