prefer gstat over stat if available (patch from #4571)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 19 Feb 2009 17:18:26 +0000 (17:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 19 Feb 2009 17:18:26 +0000 (17:18 +0000)
SVN-Revision: 14568

tools/Makefile

index c5a9933448baa116a5f84a6bbad338b294d63b25..c0bbcdbeeaab365859a44b190392e92ad4dcaba3 100644 (file)
@@ -39,8 +39,9 @@ endef
 $(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
 
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)