brcm2708: add Raspberry Pi Compute Module support
authorJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:49:27 +0000 (12:49 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 17 Jul 2015 12:49:27 +0000 (12:49 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 46403

target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
target/linux/brcm2708/image/Makefile

index 82a7910ba1089e6c2c324139d1b18c6c42d5cd78..dcf6e0599b1ff05d44de3de743719913c80e8f28 100644 (file)
@@ -28,3 +28,11 @@ define Profile/RaspberryPi_BPlus/Description
   Raspberry Pi Model B+
 endef
 $(eval $(call Profile,RaspberryPi_BPlus))
+
+define Profile/RaspberryPi_CM
+  NAME:=Raspberry Pi Compute Module
+endef
+define Profile/RaspberryPi_CM/Description
+  Raspberry Pi Model Compute Module
+endef
+$(eval $(call Profile,RaspberryPi_CM))
index 00bee225550748da25b40c0696d45ea5f872c9c9..de178c67ea6d6d4f16a984f835bde41facd776ac 100644 (file)
@@ -73,6 +73,8 @@ ifeq ($(SUBTARGET),bcm2708)
   $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
   # Raspberry Pi Model B+
   $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+  # Raspberry Pi Compute Module
+  $(eval $(call add_bcm2708,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
 endif
 
 ### BCM2709/BCM2836 ###