mbedtls: change libmbedcrypto.so soversion back to 0
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 14 Apr 2018 12:33:46 +0000 (14:33 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 14 Apr 2018 12:44:43 +0000 (14:44 +0200)
mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the
libmbedcrypto.so library, use the old version again to be able to use
the new library with binaries compiled against the old mbedtls library.

Some binaries got rebuild to for the 2.7.0 release and are now using
libmbedcrypto.so.1, the older ones are still using libmbedcrypto.so.0.
Go back to libmbedcrypto.so.0 and make the system rebuild the binaries
which were rebuild for 2.7.0 again.

This should make the libmbedcrypto.so library be compatible with the old
version shipped with 17.01.

Fixes: 3ca1438ae0 ("mbedtls: update to version 2.7.2")
Fixes: f609913b5c ("mbedtls: update to version 2.7.0")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/mbedtls/Makefile
package/libs/mbedtls/patches/300-soversion-compatibility.patch [new file with mode: 0644]
package/libs/ustream-ssl/Makefile
package/network/services/openvpn/Makefile
package/network/utils/curl/Makefile
package/utils/px5g/Makefile

index 619bbcfef1d9dabc17025f971f8f5077232b12d0..caa2405ce99ea053e740973eb191f53cf49cf96f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mbedtls
 PKG_VERSION:=2.7.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
diff --git a/package/libs/mbedtls/patches/300-soversion-compatibility.patch b/package/libs/mbedtls/patches/300-soversion-compatibility.patch
new file mode 100644 (file)
index 0000000..4d33be2
--- /dev/null
@@ -0,0 +1,26 @@
+mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the
+libmbedcrypto.so library, use the old version again to be able to use
+the new library with binaries compiled against the old library.
+
+--- a/library/CMakeLists.txt
++++ b/library/CMakeLists.txt
+@@ -141,7 +141,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
+ if(USE_SHARED_MBEDTLS_LIBRARY)
+     add_library(mbedcrypto SHARED ${src_crypto})
+-    set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 2)
++    set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 0)
+     target_link_libraries(mbedcrypto ${libs})
+     add_library(mbedx509 SHARED ${src_x509})
+--- a/library/Makefile
++++ b/library/Makefile
+@@ -33,7 +33,7 @@ endif
+ SOEXT_TLS=so.10
+ SOEXT_X509=so.0
+-SOEXT_CRYPTO=so.2
++SOEXT_CRYPTO=so.0
+ DLEXT=so
+ # OSX shared library extension:
index b9b9e19dfb1157faa375230598e0307ef279d675..95dd0e8e55eca38bdfd98190f277ec0f50ccd152 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ustream-ssl
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/ustream-ssl.git
index 7e0677baa36846c01c947c1931f86882d8013873..288a354b0e67a325ffe7fbe98d182e42b4d974bc 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
index 07056a2cd0e3c451599440b8107fd0fc6660ccce..a0abf2a85df0f7902feaad523fd0c42cc7f72b1b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.52.1
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
index 4ea495867c5b886635114254b3e80f756a16f18f..da8d56dcc0df9c2d89c3b59322618ed0647b4aab 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=px5g
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_LICENSE:=LGPL-2.1
 PKG_BUILD_DIR:=$(BUILD_DIR)/px5g-$(BUILD_VARIANT)