kernel: update kernel 4.9 to 4.9.30
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 26 May 2017 20:56:32 +0000 (22:56 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 26 May 2017 22:48:37 +0000 (00:48 +0200)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/apm821xx/patches-4.9/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-4.9/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/patches-4.9/121-of-Add-check-to-of_scan_flat_dt-before-accessing-ini.patch
target/linux/generic/patches-4.9/300-mips_expose_boot_raw.patch
target/linux/generic/patches-4.9/304-mips_disable_fpu.patch
target/linux/ipq806x/patches-4.9/0047-mtd-nand-Create-a-BBT-flag-to-access-bad-block-marke.patch
target/linux/lantiq/patches-4.9/0152-lantiq-VPE.patch
target/linux/pistachio/patches-4.9/411-mtd-nand-Check-length-of-ID-before-reading-bits-per-.patch
target/linux/ramips/patches-4.9/0901-spansion_nand_id_fix.patch

index b6af2cb590b528cf919d0f901de209f5f304b5ca..b641c5ad7ccffb2b6480a3855c89d28600604b5e 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.4 = .69
-LINUX_VERSION-4.9 = .29
+LINUX_VERSION-4.9 = .30
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 LINUX_KERNEL_HASH-4.4.69 = 207bbc50aaf827d667a2762312bd6127887cc669ff7a7270b876e7102b8f84fa
-LINUX_KERNEL_HASH-4.9.29 = 51b6df767544e593e3161b0109a6a76be18bfc9d6cc1fb7fa92b48de6cff24cf
+LINUX_KERNEL_HASH-4.9.30 = 4272ef025ce8cd717c9291b5cbe587e13c15901d8c26ceebc471af3a1d730bbb
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index e25e15bbbb43876979909f9708d102d60fad4685..91c5c1ff102324dae48013ad8c8c036236c44b7b 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -224,6 +226,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -227,6 +229,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -263,6 +717,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -266,6 +720,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* Prevent runtime suspending between USB-2 and USB-3 initialization */
-@@ -320,6 +790,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -323,6 +793,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index 66699a83f297c84b3ccd224d05f71021ede13c72..f930b39ad1875c22bc9586f702677f7ce172d093 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -188,7 +188,7 @@ static void xhci_pci_quirks(struct devic
+@@ -191,7 +191,7 @@ static void xhci_pci_quirks(struct devic
        }
        if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
                        pdev->device == 0x0015)
index b311876bdb4554cc59645f6778eabc3afc3a8ff7..3b17e9711d7e3283fa5a02cf35f678c6429956b0 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5025,7 +5025,7 @@ static void port_event(struct usb_hub *h
+@@ -5034,7 +5034,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index f939f0734c8651703ee36c35c984ab54e1f15795..bc05dcec65d0d0bd29effa100382e3d9a2cec980 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -738,9 +738,12 @@ int __init of_scan_flat_dt(int (*it)(uns
+@@ -741,9 +741,12 @@ int __init of_scan_flat_dt(int (*it)(uns
        const char *pathp;
        int offset, rc = 0, depth = -1;
  
index 9587a869f6b8ec87e2be9ac496d4c75dd6ccc53c..6925ddec6c283dd019fe55b7d89a51539413dd27 100644 (file)
@@ -18,7 +18,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2963,6 +2960,18 @@ choice
+@@ -2964,6 +2961,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index af09137257ecd1a1d2bed1de67242fcb4e54e014..a69ea5767878fc5253ae33aecc8c535c40868a8e 100644 (file)
@@ -26,7 +26,7 @@ v2: incorporated changes suggested by Jonas Gorski
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2891,6 +2891,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2892,6 +2892,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index f70821e72d60bd49af5dd8333a62ce1513dea734..0d6f990c4241c0f1431180deb2a2e7f49be98d84 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Archit Taneja <architt@codeaurora.org>
 
 --- a/drivers/mtd/nand/nand_base.c
 +++ b/drivers/mtd/nand/nand_base.c
-@@ -414,7 +414,11 @@ static int nand_default_block_markbad(st
+@@ -482,7 +482,11 @@ static int nand_default_block_markbad(st
        } else {
                ops.len = ops.ooblen = 1;
        }
index 2b6a2575f87f9ef4fa6b2dea9da123aca28dd874..101902b9372cc6f54d998730965ae466418d1972 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2310,6 +2310,12 @@ config MIPS_VPE_LOADER
+@@ -2311,6 +2311,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index ac5c16b563dd1c6d9de4239bbdf25586f043151b..f69837ae2c5eec309837aaa641bbf7f9d72ef800 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@imgtec.com>
 
 --- a/drivers/mtd/nand/nand_base.c
 +++ b/drivers/mtd/nand/nand_base.c
-@@ -3964,7 +3964,8 @@ static bool find_full_id_nand(struct mtd
+@@ -4032,7 +4032,8 @@ static bool find_full_id_nand(struct mtd
                mtd->erasesize = type->erasesize;
                mtd->oobsize = type->oobsize;
  
index 3f06afbcb383c2af2857c9374ddb4a78dba708a6..1d110cef64c1db6008364e174e5be22e1ae73f19 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
 
 --- a/drivers/mtd/nand/nand_base.c
 +++ b/drivers/mtd/nand/nand_base.c
-@@ -3767,6 +3767,7 @@ static void nand_decode_ext_id(struct mt
+@@ -3835,6 +3835,7 @@ static void nand_decode_ext_id(struct mt
        /*
         * Field definitions are in the following datasheets:
         * Old style (4,5 byte ID): Samsung K9GAG08U0M (p.32)
@@ -21,7 +21,7 @@ Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
         * New Samsung (6 byte ID): Samsung K9GAG08U0F (p.44)
         * Hynix MLC   (6 byte ID): Hynix H27UBG8T2B (p.22)
         *
-@@ -3864,6 +3865,19 @@ static void nand_decode_ext_id(struct mt
+@@ -3932,6 +3933,19 @@ static void nand_decode_ext_id(struct mt
                *busw = (extid & 0x01) ? NAND_BUSWIDTH_16 : 0;
  
                /*